Welcome to Transact

Buy It. Fix It. Love It.

Login



Your browser is a little old

Support for Windows XP ceased on 8 April 2014, and, Internet Explorer 8 is the only version of Internet Explorer that is available to use on Windows XP.

Internet Explorer 8 poses some security risks, and the newer technologies we employ are not supported on it, resulting in sites not functioning or displaying as intended. As such, and because SMD strives to deliver ground-breaking systems, we will phase out the support for Internet Explorer 8 on our SupplierPortal and Transact systems by the end of November 2014. Even though we will still support these older systems, new features will only be available in our new versions.

If you are a user of Windows XP, you will not be able to upgrade to later Internet Explorer versions. However, you can install a different browser, such as Google Chrome or Mozilla Firefox (see links below):

Users of Windows 7 or Windows 8 can upgrade their Internet Explorer versions by going to this site : http://windows.microsoft.com/en-ZA/internet-explorer/download-ie, and following the instructions.
Your request is being processed